• Aksel Lian
  • -
  • No tags

Oppdatere nettbutikk, websider og nettaplikasjoner til å støtte nyere PHP

I desember 2018 avslutter php.net sikkerhets oppdateringer til PHP 5.6 og PHP7.0

Som følge av dette er det mange hosting selskaper som avslutter støtte for disse på grunn av sikkerhetsmessige årsaker.

Alle nettsider som har PHP koding som ikke støtter nyere versjon av PHP vil dermed kunne slutte å fungere.

Oppgradering av PHP til nyere PHP 7.1 7.2

 

Enkelt forklart gjøres det mange endringer i nyere versjon av PHP. I hvert nytt versjon er det funksjoner som fases ut. Disse markeres først som utgående, slik at utviklere får tid til å tilpasse disse til gjeldende funksjoner og deretter fjernes disse fra kodespråket og vil ikke fungere.

Koder som er skrevet for en eldre versjon av PHP vil dermed måtte skrives om på nytt for å støtte nyere implementeringer og funksjonalitet.

 

Nettbutikker spesielt utsatt

I større prosjekter som nettbutikker gjøres det mye tilpasset koding som beregnes for den gjeldende versjon av nettbutikk CMSen.

Det er ofte meget krevende å flytte på en CMS nettbutikk med flere tusen produkter til nyeste versjon uten betydelig testing og oppdatering.

I mange tilfeller kan man oppdatere eldre versjon av CMS som Magento og Prestashop til å støtte for eksempel PHP 7.2

 

Hjelp med deres nettbutikk, hjemmeside

Vi kan komme med en fastpris eller tilby et av markedets laveste timepriser for utvikling som er på 890,- eksl mva.

Det vil være nødvendig å se på kildekoder og FTP tilgang for å kunne gi fastpris på prosjektet.

Kontakt oss for hjelp med deres nettløsning

Oppgradering av PHP til nyere PHP 7.1 7.2 november 9th, 2018 Aksel Lian

En selvstendig webutvikler med en bred variasjon av kunnskaper herunder SEO, CMS, Webfotografi, Webutvikling inkl. kodespråk..